Author Topic: what am I doing wrong 74 kx250  (Read 2522 times)

0 Members and 1 Guest are viewing this topic.

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
what am I doing wrong 74 kx250
« on: April 30, 2018, 06:46:06 AM »
Help!
I have a 74 KX250, ground up resto and I just cant get a decent spark. While the bike runs it runs like crap and I think its due to really weak spark.
So far I have swapped out all electrical from a bike that runs well - including the carby just to be sure. Problem remains
Could it be that the rotor has de-magnetised? Its the only bit that I haven't changed out. Spent half a day yesterday trying to figure it out - any pearls of wisdom out there - what have I missed?

DT

Offline bazza

  • Legend
  • *****
  • Posts: 2222
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #1 on: April 30, 2018, 07:32:09 AM »
Dont you love these problems Dave?
Kill switch fault?
Clean earth on frame?
Try another plug?
Once you go black  you will never go back - allblacks
Maico - B44 -1976 CR250- 66 Mustang YZF450,RM250
Embrace patina

Offline Slakewell

  • Legend
  • *****
  • Posts: 3473
  • Slakewell Motordrome
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #2 on: April 30, 2018, 07:36:40 AM »
Run a extra earth wire from the stator to the one on the coil. Maybe an air leak, Get a can of start you barstard , get the bike running and spray around the engine, if the revs pick up you have found your air leak.
Current bikes. KTM MC 250 77 Husky CR 360 77, Husky 82 420 Auto Bitsa XR 200 project.
Kawasaki A4 125 78 for sale

Offline bigk

  • Legend
  • *****
  • Posts: 2592
  • Kangaroo Flat Victoria
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #3 on: April 30, 2018, 08:06:06 AM »
It's not an electrical issue. Buy a new carby (cheap & easy to source), throw the old carby at someone you don't like.
K

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #4 on: April 30, 2018, 08:49:21 AM »
I had thought about an air leak but as I cant get a good spark in the first place I have sort of parked that idea. MH I took the carb from my 76 that is working fine problem followed.
Yes to a good earth, no kill switch involvement and multiple plugs - thanks Baz
will add another earth just to see

Offline OverTheHill

  • Legend
  • *****
  • Posts: 766
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #5 on: April 30, 2018, 09:38:56 AM »
If it starts & runs [i think] the problem lies elsewhere. CDI spark never looks 'that healthy' but would make ya hair stand on end--or fall out. No chance of something 'accidentally' left under the seat restricting air cleaner air flow. Sounds like restricted exhaust as another option, or main jet fell out or slide needle still sitting on the bench. Sorry if that sounds a bit off but more or less just letting the cat out of the bag to all the cock ups i've made over the years lol. & just when i think i've covered the field of cock ups i go & 'discover' a new one. If it's definitely electrically missing its bum off then ok--i give in & ignore all my rambling. Just tend to think if it starts--it's ok--unless they have a high speed winding separate from the initial source coil but think you said swapped stators so that ideas out the window. Cheers [or tears]. ps, i road one of those for a few meets back when new & was a very enjoyable time too--well till a rear brake shoe spring broke & locked the wheel miles from the finish of a long distance race. Very willing motor.

Offline John Orchard

  • Legend
  • *****
  • Posts: 2635
  • ^^^ Jan 1984
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #6 on: April 30, 2018, 10:06:09 AM »
l had a problem one day with a Suz RGV250 that had a weak spark and would not run clean, read somewhere that lifting the plug-cap off to about a 10mm gap resulted in an increase in voltage due the increased resistance.  Yep sure did, ran clean, put the caps back down and the bike started blubbering.

l guess these findings would prove an exciter coil not creating enough power? Maybe from a weak magnet?
Johnny O - Tahition_Red factory rider.

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #7 on: April 30, 2018, 01:16:02 PM »
John - that's were I'm at, 3 different coils and stators, couple of CDI just in case and no improvement. need to get a puller now and try that I guess - I do have a spare
appreciate the help one and all
DT

Offline Mick D

  • Legend
  • *****
  • Posts: 2892
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #8 on: April 30, 2018, 02:47:28 PM »
Ok Dave, a weak spark will certainly make for difficult starting and poor running.  Shows up when opening the throttle, especially under load.

You have swapped out a lot, except for magnetic rotor?

These days I test the magnetism of every rotor that pass through my hands.
I have a jar of m6 nuts.
I lightly hand engrave the result of how many on each tested rotor(then highlight with paint marker or texta). All other info on rotors is factory stamped so there is no mix up with a hand engraved figure.

I have noticed massive variations of magnetism on identical to look at OLD ROTORS.

It is no problem if you don't have a puller yet and want to compare or confirm your suspicions.
You can see how many nails or whatever while it is still mounted on a steel crank end.
I have noticed little to no difference whether testing its capacity while mounted on a crank or removed.

I also include an earth wire between all ignition components when I make harnesses.

Hope this helps a bit?
Have fun  :) 
« Last Edit: April 30, 2018, 02:50:44 PM by Mick D »
"light weight, and it works great"  :)

Offline pokey

  • Legend
  • *****
  • Posts: 1283
  • Arse .. Elbow. Know the difference
    • View Profile
    • FB
Re: what am I doing wrong 74 kx250
« Reply #9 on: April 30, 2018, 04:02:54 PM »
Sounds like a lot of guess work going on and thats okay some of the time but when it doesnt work its time to make sure Break out the multimeter and test ALL compoents and make sure they are within spec.. Cpil cdi, primery and exciter...doesnt take long.
 Do a leak down test for the bottom end seals .
 pull the carb and and doable check your float and jets are correct.

 also check your plug cap. make sure its the right type for your bike as some dont like resister caps.



 as mentioned, its a new build so earths may be not as good as they should be with paint pr PC. Make sure you have a decent earth or even run an extra wire .
 

Offline LWC82PE

  • Superstar
  • ******
  • Posts: 5823
    • View Profile
    • PE motorcycles & SuzukiTS.com
Re: what am I doing wrong 74 kx250
« Reply #10 on: April 30, 2018, 05:27:43 PM »
Weak flywheel magnets could definitely be an issue.
Wanted - 1978 TS185 frame or frame&motor. Frame # TS1852-24007 up to TS1852-39022

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #11 on: May 01, 2018, 07:00:26 AM »
Thanks all - great tips.
going to pull the rotor this weekend and see if that makes the difference
when the thing runs it runs like crap, I thought about the main seals and still consider this as a possibility but usually the bike will be at least rideable down low and breakdown up top - this thing is crap across the range.
I think that once I can get a decent spark I have a base to work from, comparing my 76 and 78 KX250s the difference is obvious, big blue sparks compared to almost nothing from the 74. The only thing I haven't changed is the rotor!
Full report next week
Thanks again
DT

Offline John Orchard

  • Legend
  • *****
  • Posts: 2635
  • ^^^ Jan 1984
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #12 on: May 01, 2018, 09:47:04 AM »
Can flywheel rotors be re magnified?
Johnny O - Tahition_Red factory rider.

Offline Mick D

  • Legend
  • *****
  • Posts: 2892
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #13 on: May 01, 2018, 12:41:23 PM »
Can flywheel rotors be re magnified?

Yes
"light weight, and it works great"  :)

Offline matcho mick

  • Legend
  • *****
  • Posts: 2225
    • View Profile
    • Moto Tumbi
Re: what am I doing wrong 74 kx250
« Reply #14 on: May 01, 2018, 06:16:35 PM »
takes a pretty big magnifier to do rotors,usually glass ones  ::), :P
work,the curse of the racing class!!
if a hammer dosn't fix it,you have a electrical problem!!

Offline John Orchard

  • Legend
  • *****
  • Posts: 2635
  • ^^^ Jan 1984
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #15 on: May 01, 2018, 07:41:28 PM »
takes a pretty big magnifier to do rotors,usually glass ones  ::), :P


Ha ha oops  ;-)
Johnny O - Tahition_Red factory rider.

Online Hoony

  • Legend
  • *****
  • Posts: 4115
  • Melbourne, Vic.
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #16 on: May 01, 2018, 07:46:07 PM »
takes a pretty big magnifier to do rotors,usually glass ones  ::), :P


Ha ha oops  ;-)
Long time Honda Fan, but all bike nut in general, Big Bore 2 stroke fan.    http://www.youtube.com/watch?v=XJoKP6MawYI
1985 Honda CR500RF "Big Red"
1986 Honda CR250RG
2005 KTM 300EXC "The GruntMeister" ( I love that engine)

Offline bazza

  • Legend
  • *****
  • Posts: 2222
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #17 on: May 02, 2018, 08:21:05 AM »
Dave put a AJS electrical system on.....lol
Once you go black  you will never go back - allblacks
Maico - B44 -1976 CR250- 66 Mustang YZF450,RM250
Embrace patina

Offline Kane Mcguire

  • A-Grade
  • ****
  • Posts: 353
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #18 on: May 06, 2018, 04:55:44 PM »
Has this problem been solved??

Offline OverTheHill

  • Legend
  • *****
  • Posts: 766
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #19 on: May 07, 2018, 11:12:19 AM »
Has this problem been solved??
I see i've my nose in this one back a page so Bump--be nice ta know how it's getting on. Thanks.

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #20 on: May 08, 2018, 12:01:28 PM »
wife had differing plans for the QLD long weekend so didn't get to it - will do as soon as possible! Imagine the day when I make plans that alter the course of my wife's weekend - that day aint coming any time soon....

one must do as one is told - apparently.....


Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #21 on: June 02, 2018, 04:53:45 PM »
OK
there story is that a new rotor made no difference.
The summary is
carb from my 76 that works fine - same engine it should work fine on the 74
multiple ignition, stator, coil, and now rotor - no difference
port heights look fine, piston around the right way and everything opens and closes like it should
but
it runs like shit - almost nothing blubbering down low, better in the top end but not fantastic. This is the thing that gets me - in all the main seals its the top end that is bad when a seal is gone.
really oily - dripping out so right now Im looking at the right side main seal - thats about where im at short of a crank case gasket leak.......
perhaps the best thing would be shelve the motor and get another and start again!!!!

211

Offline Momus

  • A-Grade
  • ****
  • Posts: 494
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #22 on: June 02, 2018, 05:57:28 PM »
RM370 did the crap running down low when I got it.

New genuine crank seals, checked the mating faces, replaced the center case gasket and the phillips head screws with cap screws to get decent tension- std screws were not tight  (I suspected a possible intermittent 'wet' leak from the gearbox), and it was a lot better. It wasn't until I put a new cylinder and piston on it though that it was 100%.


The original cylinder was ok- ring end gap was well within spec and skirt clearance respectable and so on. Perhaps swap top ends from your 76 to rule that out?

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #23 on: June 02, 2018, 06:40:54 PM »
Had thought about the piston - its a 40 year old Wiseco and I have never been a fan, it was all I could get. I have another Barrel, have a new sleeve - may be thats the next step after the 76 test??

Offline pokey

  • Legend
  • *****
  • Posts: 1283
  • Arse .. Elbow. Know the difference
    • View Profile
    • FB
Re: what am I doing wrong 74 kx250
« Reply #24 on: June 03, 2018, 08:24:39 AM »
Rh seal hmmm maybe.. maybe nor. Would have noticed the hot car smell from different oil . Gearbox oil also goes milky.

Leakdown test would verify bottom end.

Have we burnt the pipe out lately? A carboned pipe wont make it run fabulous and with all that unburnt oil im guessing the pipe isnt doing its job.

Offline evo550

  • Legend
  • *****
  • Posts: 2424
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #25 on: June 03, 2018, 09:20:34 AM »
When you did the carb swap from the 76, Did you bring across the slide/needle as well or just the carb body and used the 74 slide/needle?

Offline bigk

  • Legend
  • *****
  • Posts: 2592
  • Kangaroo Flat Victoria
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #26 on: June 03, 2018, 09:37:15 AM »
If you don't like Wiseco, use an Elsinore 250 piston (used them in '74 KX a few times), of which there are other brand options.
K

Offline OverTheHill

  • Legend
  • *****
  • Posts: 766
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #27 on: June 03, 2018, 11:01:01 AM »
Was just going to get my teeth into this [most teeth mithing] but see i've rambled on back a page so i'll just re-run it as pretty much covers my thoughts. loved the one i rode when new or almost new--must have a pic somewhere, front wheel in the air passing my boss on his yz360b mono up a track. Hope ya get it sorted. Not reed valve so can't have piston back to front--well can but not the problem. Someone [apprentice] not made a base gasket for you & omitted to cut out for the transfers?, don't laugh i've seen it happen, ran but only just. Ok, wifey's home--yes dear i've been busy!!--panic. Just reinforce cleaning the exhaust & if in doubt then cut it open or at least slide a garden hose or something down the tail pipe to be sure she aint restricted at the weld where tail pipe joins. Plus be sure of muffler internals. Got caught out once on a GoKart which went like hell i thought but not compared to another identical Racket motor or something with a vacuum power valve & muffler was collapsing inside & partialy blocking the pipe.

If it starts & runs [i think] the problem lies elsewhere. CDI spark never looks 'that healthy' but would make ya hair stand on end--or fall out. No chance of something 'accidentally' left under the seat restricting air cleaner air flow. Sounds like restricted exhaust as another option, or main jet fell out or slide needle still sitting on the bench. Sorry if that sounds a bit off but more or less just letting the cat out of the bag to all the cock ups i've made over the years lol. & just when i think i've covered the field of cock ups i go & 'discover' a new one. If it's definitely electrically missing its bum off then ok--i give in & ignore all my rambling. Just tend to think if it starts--it's ok--unless they have a high speed winding separate from the initial source coil but think you said swapped stators so that ideas out the window. Cheers [or tears]. ps, i road one of those for a few meets back when new & was a very enjoyable time too--well till a rear brake shoe spring broke & locked the wheel miles from the finish of a long distance race. Very willing motor.
« Last Edit: June 03, 2018, 11:09:51 AM by OverTheHill »

Offline Slakewell

  • Legend
  • *****
  • Posts: 3473
  • Slakewell Motordrome
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #28 on: June 03, 2018, 05:23:38 PM »
Maybe the crank shaft is bent? Letting air in? I hope to see you at CD Dave for a beer or two. Come over and take the A4 for a few laps.
« Last Edit: June 03, 2018, 05:37:10 PM by Slakewell »
Current bikes. KTM MC 250 77 Husky CR 360 77, Husky 82 420 Auto Bitsa XR 200 project.
Kawasaki A4 125 78 for sale

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #29 on: June 04, 2018, 08:35:55 AM »
thanks all
going to burn out the pipe and see whats going on - full report soon
appreciate all the help!!
Mick - going to CD on Sunday for a look - possibly riding the H2 but not riding at CD, see u there.

Offline bazza

  • Legend
  • *****
  • Posts: 2222
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #30 on: June 04, 2018, 02:48:08 PM »
Dave soaked my 76 Cr pipe in caustic soda bath at mates work, end result was it reved out on top end
Once you go black  you will never go back - allblacks
Maico - B44 -1976 CR250- 66 Mustang YZF450,RM250
Embrace patina

Offline Slakewell

  • Legend
  • *****
  • Posts: 3473
  • Slakewell Motordrome
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #31 on: June 04, 2018, 06:35:46 PM »
My old man who ran a small motor shop for most of his life taught me most of what I know. Start with the basics my boy he would say for problems like this. He would remove the pipe and the carby he would have an old sauce bottle with fuel in it. He would start the engine and spay in some fuel to keep it running for a few minutes with the bottle if it ran fine he would say must be air and fuel. If ran like shite he would say must be electrics.
Current bikes. KTM MC 250 77 Husky CR 360 77, Husky 82 420 Auto Bitsa XR 200 project.
Kawasaki A4 125 78 for sale

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #32 on: June 05, 2018, 06:52:56 AM »
you know it shits me a tad, my daughters GTMX80 (1978) always ran like crap, Jane knew no difference and it stayed slow so I didn't worry too much, she rode it for years on the farm like that and loved it. I got the engine rebuilt after 38 years of kids flogging it and it still ran like crap so I burnt out the pipe and it went from a slug to a rocket.

Now I just want to know if I have the same thing, the simple stuff sometimes gets missed when your overthinking a problem. Full report soon.

DT

Offline 80-85 husky

  • Legend
  • *****
  • Posts: 3643
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #33 on: June 05, 2018, 08:21:00 AM »
i use a honda firefighter to transfer water occasionally. it started playing up then would only fire  every so often. i cleaned the carb..no improvement >:( i have a spare engine so i replaced the carb..no different... i replaced the ignition system and the plug lead and cap and plug and airfilter ...still no result :-X....put 100ml of oil in and away it went....stupid oil alert switch!

Offline 211

  • A-Grade
  • ****
  • Posts: 320
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #34 on: June 09, 2018, 09:27:26 PM »
Pipe didn't work - engines coming out...........

Offline OverTheHill

  • Legend
  • *****
  • Posts: 766
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #35 on: June 09, 2018, 11:36:16 PM »
Oh bugger. Be real good to have someone take a good long video with good audio while you're running it. Just seems a shame to pull it apart again. Unless it's popped crank seal out or something in which case carburetion would be all to hell & gaspy, or smoking & gaspy if the right side seal. I don't know if they're inboard or outboard seals, as in easily replaced or a dismantle job.

Offline bazza

  • Legend
  • *****
  • Posts: 2222
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #36 on: June 11, 2018, 12:50:58 PM »
seal?  This is why we love bikes...LOL
Once you go black  you will never go back - allblacks
Maico - B44 -1976 CR250- 66 Mustang YZF450,RM250
Embrace patina