Author Topic: what am I doing wrong 74 kx250  (Read 1064 times)

0 Members and 1 Guest are viewing this topic.

Offline 211

  • A-Grade
  • ****
  • Posts: 312
    • View Profile
what am I doing wrong 74 kx250
« on: April 30, 2018, 06:46:06 AM »
Help!
I have a 74 KX250, ground up resto and I just cant get a decent spark. While the bike runs it runs like crap and I think its due to really weak spark.
So far I have swapped out all electrical from a bike that runs well - including the carby just to be sure. Problem remains
Could it be that the rotor has de-magnetised? Its the only bit that I haven't changed out. Spent half a day yesterday trying to figure it out - any pearls of wisdom out there - what have I missed?

DT

Offline bazza

  • Legend
  • *****
  • Posts: 2205
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #1 on: April 30, 2018, 07:32:09 AM »
Dont you love these problems Dave?
Kill switch fault?
Clean earth on frame?
Try another plug?
Once you go black  you will never go back - allblacks
Maico - B44 -1976 CR250- 66 Mustang YZF450,RM250
Embrace patina

Offline Slakewell

  • Legend
  • *****
  • Posts: 3448
  • Slakewell Motordrome
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #2 on: April 30, 2018, 07:36:40 AM »
Run a extra earth wire from the stator to the one on the coil. Maybe an air leak, Get a can of start you barstard , get the bike running and spray around the engine, if the revs pick up you have found your air leak.
Current bikes. KTM MC 250 77 Husky CR 360 77, Husky 82 420 Auto Bitsa XR 200 project.
Kawasaki A4 125 78 for sale

Offline bigk

  • Legend
  • *****
  • Posts: 2579
  • Kangaroo Flat Victoria
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #3 on: April 30, 2018, 08:06:06 AM »
It's not an electrical issue. Buy a new carby (cheap & easy to source), throw the old carby at someone you don't like.
K

Offline 211

  • A-Grade
  • ****
  • Posts: 312
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #4 on: April 30, 2018, 08:49:21 AM »
I had thought about an air leak but as I cant get a good spark in the first place I have sort of parked that idea. MH I took the carb from my 76 that is working fine problem followed.
Yes to a good earth, no kill switch involvement and multiple plugs - thanks Baz
will add another earth just to see

Offline OverTheHill

  • Legend
  • *****
  • Posts: 751
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #5 on: April 30, 2018, 09:38:56 AM »
If it starts & runs [i think] the problem lies elsewhere. CDI spark never looks 'that healthy' but would make ya hair stand on end--or fall out. No chance of something 'accidentally' left under the seat restricting air cleaner air flow. Sounds like restricted exhaust as another option, or main jet fell out or slide needle still sitting on the bench. Sorry if that sounds a bit off but more or less just letting the cat out of the bag to all the cock ups i've made over the years lol. & just when i think i've covered the field of cock ups i go & 'discover' a new one. If it's definitely electrically missing its bum off then ok--i give in & ignore all my rambling. Just tend to think if it starts--it's ok--unless they have a high speed winding separate from the initial source coil but think you said swapped stators so that ideas out the window. Cheers [or tears]. ps, i road one of those for a few meets back when new & was a very enjoyable time too--well till a rear brake shoe spring broke & locked the wheel miles from the finish of a long distance race. Very willing motor.

Offline John Orchard

  • Legend
  • *****
  • Posts: 2617
  • ^^^ Jan 1984
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #6 on: April 30, 2018, 10:06:09 AM »
l had a problem one day with a Suz RGV250 that had a weak spark and would not run clean, read somewhere that lifting the plug-cap off to about a 10mm gap resulted in an increase in voltage due the increased resistance.  Yep sure did, ran clean, put the caps back down and the bike started blubbering.

l guess these findings would prove an exciter coil not creating enough power? Maybe from a weak magnet?
Johnny O - Tahition_Red factory rider.

Offline 211

  • A-Grade
  • ****
  • Posts: 312
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #7 on: April 30, 2018, 01:16:02 PM »
John - that's were I'm at, 3 different coils and stators, couple of CDI just in case and no improvement. need to get a puller now and try that I guess - I do have a spare
appreciate the help one and all
DT

Offline Mick D

  • Legend
  • *****
  • Posts: 2884
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #8 on: April 30, 2018, 02:47:28 PM »
Ok Dave, a weak spark will certainly make for difficult starting and poor running.  Shows up when opening the throttle, especially under load.

You have swapped out a lot, except for magnetic rotor?

These days I test the magnetism of every rotor that pass through my hands.
I have a jar of m6 nuts.
I lightly hand engrave the result of how many on each tested rotor(then highlight with paint marker or texta). All other info on rotors is factory stamped so there is no mix up with a hand engraved figure.

I have noticed massive variations of magnetism on identical to look at OLD ROTORS.

It is no problem if you don't have a puller yet and want to compare or confirm your suspicions.
You can see how many nails or whatever while it is still mounted on a steel crank end.
I have noticed little to no difference whether testing its capacity while mounted on a crank or removed.

I also include an earth wire between all ignition components when I make harnesses.

Hope this helps a bit?
Have fun  :) 
« Last Edit: April 30, 2018, 02:50:44 PM by Mick D »
"light weight, and it works great"  :)

Offline pokey

  • Legend
  • *****
  • Posts: 1270
  • Arse .. Elbow. Know the difference
    • View Profile
    • FB
Re: what am I doing wrong 74 kx250
« Reply #9 on: April 30, 2018, 04:02:54 PM »
Sounds like a lot of guess work going on and thats okay some of the time but when it doesnt work its time to make sure Break out the multimeter and test ALL compoents and make sure they are within spec.. Cpil cdi, primery and exciter...doesnt take long.
 Do a leak down test for the bottom end seals .
 pull the carb and and doable check your float and jets are correct.

 also check your plug cap. make sure its the right type for your bike as some dont like resister caps.



 as mentioned, its a new build so earths may be not as good as they should be with paint pr PC. Make sure you have a decent earth or even run an extra wire .
 

Offline LWC82PE

  • Superstar
  • ******
  • Posts: 5801
    • View Profile
    • PE motorcycles & SuzukiTS.com
Re: what am I doing wrong 74 kx250
« Reply #10 on: April 30, 2018, 05:27:43 PM »
Weak flywheel magnets could definitely be an issue.
Wanted - 1978 TS185 frame or frame&motor. Frame # TS1852-24007 up to TS1852-39022

Offline 211

  • A-Grade
  • ****
  • Posts: 312
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #11 on: May 01, 2018, 07:00:26 AM »
Thanks all - great tips.
going to pull the rotor this weekend and see if that makes the difference
when the thing runs it runs like crap, I thought about the main seals and still consider this as a possibility but usually the bike will be at least rideable down low and breakdown up top - this thing is crap across the range.
I think that once I can get a decent spark I have a base to work from, comparing my 76 and 78 KX250s the difference is obvious, big blue sparks compared to almost nothing from the 74. The only thing I haven't changed is the rotor!
Full report next week
Thanks again
DT

Offline John Orchard

  • Legend
  • *****
  • Posts: 2617
  • ^^^ Jan 1984
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #12 on: May 01, 2018, 09:47:04 AM »
Can flywheel rotors be re magnified?
Johnny O - Tahition_Red factory rider.

Offline Mick D

  • Legend
  • *****
  • Posts: 2884
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #13 on: May 01, 2018, 12:41:23 PM »
Can flywheel rotors be re magnified?

Yes
"light weight, and it works great"  :)

Offline matcho mick

  • Legend
  • *****
  • Posts: 2217
    • View Profile
    • Moto Tumbi
Re: what am I doing wrong 74 kx250
« Reply #14 on: May 01, 2018, 06:16:35 PM »
takes a pretty big magnifier to do rotors,usually glass ones  ::), :P
work,the curse of the racing class!!
if a hammer dosn't fix it,you have a electrical problem!!

Offline John Orchard

  • Legend
  • *****
  • Posts: 2617
  • ^^^ Jan 1984
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #15 on: May 01, 2018, 07:41:28 PM »
takes a pretty big magnifier to do rotors,usually glass ones  ::), :P


Ha ha oops  ;-)
Johnny O - Tahition_Red factory rider.

Offline Hoony

  • Legend
  • *****
  • Posts: 4093
  • Melbourne, Vic.
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #16 on: May 01, 2018, 07:46:07 PM »
takes a pretty big magnifier to do rotors,usually glass ones  ::), :P


Ha ha oops  ;-)
Long time Honda Fan, but all bike nut in general, Big Bore 2 stroke fan.    http://www.youtube.com/watch?v=XJoKP6MawYI
1985 Honda CR500RF "Big Red"
1986 Honda CR250RG
2005 KTM 300EXC "The GruntMeister" ( I love that engine)

Offline bazza

  • Legend
  • *****
  • Posts: 2205
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #17 on: May 02, 2018, 08:21:05 AM »
Dave put a AJS electrical system on.....lol
Once you go black  you will never go back - allblacks
Maico - B44 -1976 CR250- 66 Mustang YZF450,RM250
Embrace patina

Offline Kane Mcguire

  • A-Grade
  • ****
  • Posts: 352
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #18 on: May 06, 2018, 04:55:44 PM »
Has this problem been solved??

Offline OverTheHill

  • Legend
  • *****
  • Posts: 751
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #19 on: May 07, 2018, 11:12:19 AM »
Has this problem been solved??
I see i've my nose in this one back a page so Bump--be nice ta know how it's getting on. Thanks.

Offline 211

  • A-Grade
  • ****
  • Posts: 312
    • View Profile
Re: what am I doing wrong 74 kx250
« Reply #20 on: May 08, 2018, 12:01:28 PM »
wife had differing plans for the QLD long weekend so didn't get to it - will do as soon as possible! Imagine the day when I make plans that alter the course of my wife's weekend - that day aint coming any time soon....

one must do as one is told - apparently.....