Author Topic: Swm not revving out?  (Read 7583 times)

0 Members and 1 Guest are viewing this topic.

Offline hampster

  • B-Grade
  • ***
  • Posts: 204
    • View Profile
Swm not revving out?
« on: December 28, 2014, 05:23:16 PM »
Hi all,
 
My tf1 250 starts first kick idles fine , till mid throttle than seems to brakes down ? Sound like its electrical the ignition system has been re wound looks a bit average does any body know where I can get a new electric system?

Thanks chris

Offline Slakewell

  • Legend
  • *****
  • Posts: 3488
  • Slakewell Motordrome
    • View Profile
Re: Swm not revving out?
« Reply #1 on: December 28, 2014, 05:26:40 PM »
Why not PVL? or similar?

Have you tried it with no Muffler or air-filter? 
Current bikes. KTM MC 250 77 Husky CR 360 77, Husky 82 420 Auto Bitsa XR 200 project. Dont need a pickle just need to ride my motorcickle

mainline

  • Guest
Re: Swm not revving out?
« Reply #2 on: December 28, 2014, 05:54:17 PM »
Try disconnecting the kill switch, may have a dodgy connection, not earthed properly etc
« Last Edit: December 28, 2014, 08:14:10 PM by mainline »

Offline bigk

  • Legend
  • *****
  • Posts: 2606
  • Kangaroo Flat Victoria
    • View Profile
Re: Swm not revving out?
« Reply #3 on: December 28, 2014, 09:58:53 PM »
Don't discount carburetion, check needle & needle jet are not worn.
K

Offline shortshifter

  • Legend
  • *****
  • Posts: 667
  • Sunshine Coast QLD
    • View Profile
Re: Swm not revving out?
« Reply #4 on: January 02, 2015, 06:55:31 PM »
Hi Hamster.Seem to remember a rebuilt Husky with same problem,guy tried everything to fix it.Turned out it was the muffler restricting the engine ;)

Offline Bamford#69

  • A-Grade
  • ****
  • Posts: 417
    • View Profile
Re: Swm not revving out?
« Reply #5 on: January 02, 2015, 08:54:16 PM »
Hi,
have look at Fuel tank breather , and take fuel line off and check fuel line/tap flow,
cheers

Offline oldyzman

  • Legend
  • *****
  • Posts: 2182
  • 250 two stroke!
    • View Profile
Re: Swm not revving out?
« Reply #6 on: January 02, 2015, 09:08:19 PM »
Recently purchased a cr250 1989 "race ready" was also weak at high RPM. Changed the muffler and put back to std jetting was a bit rich. Goes really well now.
Once your bike is warmed up does it still blow heaps of smoke mid range?
Brett
I have a soft spot japanese mxers with aluminium tanks. Two stroke classic Dirt Track...

Offline supermotomc

  • C-Grade
  • **
  • Posts: 83
  • SWM ktm, dealer mechanic 1977-1995
    • View Profile
Re: Swm not revving out?
« Reply #7 on: January 04, 2015, 10:21:15 AM »
so what have you touched or did this just appear have you worked on this before you got the earth wire on this 12v to earth ok have you had the disc valve out??
« Last Edit: January 04, 2015, 10:25:29 AM by supermotomc »

Offline kim80y

  • C-Grade
  • **
  • Posts: 142
    • View Profile
Re: Swm not revving out?
« Reply #8 on: January 04, 2015, 04:43:51 PM »
I had a similar problem for a long time, and it was the HT coil, there was a "bad batch" of aftermarket ones floating around, I had two of them before the importer fessed up........

Cheers
Kim ::)

Offline hampster

  • B-Grade
  • ***
  • Posts: 204
    • View Profile
Re: Swm not revving out?
« Reply #9 on: January 07, 2015, 09:39:59 AM »
Thanks All,

Have tried the following,
The bike is running a 34 mm Dellorto have put in standard new main jet , pilot jet , needle , needle and seat. No change.
Run the  bike with the petrol tank cap off seems to have plenty of fuel, no change.
Have taken off the muffler and run , no change.
Have taken out the air filter and run , did make it run worse ?
Have varied the timing,  advanced and retarded , backfired a bit when advanced?
Have tried a colder plug a 9, no change.
Still starts first kick and idle fine till mid-throttle?
The stator has been rewound and looks a bit dodgy?

Yet again any help would be much appreciated

Chris.
« Last Edit: January 07, 2015, 09:42:07 AM by hampster »

Offline Lozza

  • Legend
  • *****
  • Posts: 4202
    • View Profile
Re: Swm not revving out?
« Reply #10 on: January 07, 2015, 11:00:35 PM »
VHSB or PHBE carby?  Can you tell me the main jet, needle, atomiser tube and I'll check the fuel curve
Jesus only loves two strokes

mainline

  • Guest
Re: Swm not revving out?
« Reply #11 on: January 07, 2015, 11:49:46 PM »
Try disconnecting the kill switch, may have a dodgy connection, not earthed properly etc

Offline pokey

  • Legend
  • *****
  • Posts: 1313
  • Arse .. Elbow. Know the difference
    • View Profile
    • FB
Re: Swm not revving out?
« Reply #12 on: January 08, 2015, 12:12:25 AM »
Any chance of posting a pic of the plug?
to me it sounds like an air leak . specially seeing as allowing more air by removing the filter makes it run worse.

Offline Mick D

  • Legend
  • *****
  • Posts: 2900
    • View Profile
Re: Swm not revving out?
« Reply #13 on: January 08, 2015, 12:42:56 PM »
Hi Chris, Mid throttle,
Fuel maybe??
Mid throttle = needle jet

Have you completely stripped the carb to make sure?
Removed the emulsion tube?
100% sure that the air draft passage from the bottom of the air horn to the emulsion tube is clear?

Worth verifying, good luck.
« Last Edit: January 08, 2015, 02:18:14 PM by Mick D »
"light weight, and it works great"  :)

Offline Canam370

  • Legend
  • *****
  • Posts: 1595
    • View Profile
Re: Swm not revving out?
« Reply #14 on: January 08, 2015, 04:15:30 PM »
I don't know if anyones asked but was the onset of the issue sudden or progressive? Sudden would point towards electrics (the Bosch CDI's weren't startling). The stators were generally OK. Multimeter checks won't always show up a fault. Send the lot off to be checked dynamically by a professional -  including the kill button -  it'll be cheaper than shotgun solutions to imagined repairs. Particularly if someones already monstered the electrics.
 Progressive deterioration leads down a whole different fault tree analysis.
WANTED. Canams;all models,complete or parts.SWM stuff too!

I'm THE Thread Killer - when I post a thread dies!